🔍
📢

OpenWrt 19.07.0 - 嵌入式路由器设备操作系统固件

OpenWrt是一个为嵌入式设备设计的一款Linux操作系统,它可以用于替换庞大数量的无线路由器 以及非网络设备的原厂固件。

 

使用系统升级页面可以在保留原有配置的情况下顺利的将 OpenWrt 18.06 升级到 OpenWrt 19.07。 但是无论如何,我们还是建议在升级到 OpenWrt 19.07 之前,创建一个配置文件的备份以防万一。

 

OpenWrt 19.07 中的功能亮点


OpenWrt社区在此非常自豪地发布 OpenWrt 19.07 系列的首个稳定版。这个版本相对于 18.06.0 版本新增了 3954 次提交 ,相对于 19.07.0-rc2 候选版新增了 85 次提交。

在这个版本中,OpenWrt 项目将所有的设备的内核都升级到了统一的版本。这个内核还将持续的完善中,为更多的设备带来支持。 这个版本引入了对 ath79 系列设备的支持,以及对 WPA3 协议的支持。

 

从 ar71xx 系列向 ath79 系列转移


此版本为 ar71xx 系列的基于设备树的继任者——ath79 系列——提供了初始支持。在 19.07 版本中,两个版本都会将继续构建,但我们建议在可能的情况下,切换到新的 ath79 系列。后续的 OpenWrt 可能会放弃对 ar71xx 的支持。

请在升级前阅读下面的已知问题章节。

 

WPA3 支持


19.07 版本带来了初始的 WPA3 支持,但在默认情况不启用。若需要启用 WPA3 功能,需要安装下面的软件包:对于一个 WPA3 接入点 (AP),需要安装 hostapd-openssl 软件包;对于一个 WPA3 路由器(Station),需要安装 wpa-supplicant-openssl(仅Station模式)或 wpad-openssl (AP + station)。因这些软件包的体积过大,无法默认安装,并且也不可能在存储空间小于8MB的设备上安装。

注意,许多现存的设备可能永远不会支持 WPA3,某些支持 WPA2 的设备也可能无法连接到一个配置为 WPA2 + WPA3 混合模式的接入点。如果你需要报告关于 WPA3 的问题,请先确保这些问题不是客户端导致的。

要将你的设备配置为 WPA3 接入点,请参考 wpa_modes

 

LuCI 网页界面的客户端渲染模式


OpenWrt 内置的新版本的 LuCI,实现了名为“客户端渲染”的技术。这项技术将部分渲染代码从服务端(Lua代码)移动到浏览器(JS代码),能够提高路由器的性能。

但 LuCI 生态系统非常复杂,不是所有的 LuCI 软件都能够兼容此项改动。如果你遇到了因 cbi.lua 缺失造成的崩溃,请尝试安装 luci-compat 软件包。

通过这项技术,LuCI 内的 Lua 代码量减少了,LuCI 的性能也在没有完全重写的情况下接近 LuCI2 的性能。

 

已知问题


ar71xx 系列和 ath79 系列的相互升级当前不受官方支持,建议为所有被 ar71xx 和 ath79 支持的设备手工重新安装。
某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复
可能的 5GHz Wi-Fi 信号问题。如果你遇到了这类问题,请查看现有的 BUG 报告 (FS#2679, FS#2563, FS#2682) 或 新增一个BUG报告。请确保这些问题不是由 WPA3 导致的。如果你正在使用 WPA3 并出现了问题,请尝试恢复到升级 19.07 之前的配置。


OpenWrt 19.07.0 的主要变更


此版本相对于 Openwrt 18.06 版本的变更主要有:

更新工具链:
musl libc 1.1.24
uClibc-ng 1.0.31
glibc 2.27
gcc 7.5.0
binutils 2.31.1
更新 Linux 内核
所有设备都升级到 4.14.162
网络流量分载修正
用户级网络:
hostapd 2.9, dnsmasq 2.80, dropbear 2019.78
网络和无线配置处理的修正
WPA3 配置的支持
安装 wpad-openssl 以获取 WPA3 的支持
文档: wpa_modes
用户级系统:
busybox 1.30.1
系统升级支持备份和升级兼容性检测
新增了 urngd,一个基于时间抖动的非物理真随机数发生器服务
进程管理器、系统消息总线、内置 Web 服务器和配置管理库的修复
平台和驱动支持
放弃对 adm5120, adm8668, ar7, au1000, ixp4xx, mcs814x, omap24xx, ppc40x, ppc44x 和 xburst 系列的支持
新的 ath79 系列将会取代 ar71xx 系列
所有系列的新设备支持和更新
LuCI Web 界面:
引入了客户端渲染,提高了性能
安全性修复
完整的变更列表请参阅更新日志。

一如既往的衷心感谢各位活动的软件包维护者、测试者、文档编写者和支持者的贡献。

祝各位用得开心!

OpenWrt 项目组